Degraded performance in edit mode
Incident Report for Superblocks
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 17:10 EST
Investigating
We are investigating reports of slowness and 500 errors in edit mode.
Posted Nov 20, 2024 - 15:52 EST
This incident affected: Editor.