Applications are blank, until you hard refresh your browser
Incident Report for Superblocks
Resolved
We have confirmed that the fix applied at 21:20 EDT has resolved this issue.
Posted Sep 27, 2023 - 21:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2023 - 21:20 EDT
Update
We are working on an improvement to the caching behavior to prevent this issue from affecting more users.
Posted Sep 27, 2023 - 20:05 EDT
Identified
Due to browser caching, you must do a Hard Refresh of your browser to get the latest application state.

In Chrome, you can Hard Refresh using Command + Shift + R, or by right clicking the refresh button and choosing Hard Refresh.
Posted Sep 27, 2023 - 19:51 EDT
This incident affected: Applications.